summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-22 08:25:28 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-22 08:27:26 +0200
commitae9572ee90135123782d7327420f405694ecbe55 (patch)
tree417d2f5e6796d75ab1fd3c7d333496fda5e7e3c8 /dev-python/django-taggit
parentdev-python/pytest-check: add 1.1.2 (diff)
downloadgentoo-ae9572ee90135123782d7327420f405694ecbe55.tar.gz
gentoo-ae9572ee90135123782d7327420f405694ecbe55.tar.bz2
gentoo-ae9572ee90135123782d7327420f405694ecbe55.zip
dev-python/django-taggit: add 3.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/django-taggit')
-rw-r--r--dev-python/django-taggit/Manifest1
-rw-r--r--dev-python/django-taggit/django-taggit-3.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-taggit/Manifest b/dev-python/django-taggit/Manifest
index ccbf137bfb70..ee6e6c0d257e 100644
--- a/dev-python/django-taggit/Manifest
+++ b/dev-python/django-taggit/Manifest
@@ -1 +1,2 @@
DIST django-taggit-3.0.0.tar.gz 57380 BLAKE2B 67ce6adde1bcba3a9fc8f11af4135dd1a2ee75892e26d4de9970f84111c1cf73f65bc58a2de45c75b98b0c5da9b8a6077af76d1e0561ce8a5e78828db8f40226 SHA512 e44a5f4f8293560cecb1ba39035241f209f21803521d3e2f3102e04add9778ebc15b0da6994f0a51b6c55274318b4cabce33805952f8bbaad16ecc3c03070e10
+DIST django-taggit-3.1.0.tar.gz 58238 BLAKE2B ea5c90300383294daf80315b013dc1171d94fe4994cdf58a9364666a879672bd5af35f3c620673cb0a9139d2a224bc06d58f933ae94ccd8a65b947c76ab0a0ca SHA512 8654b703cb9b3848a5185f1b88826a80eed44f00993d6272e8fbec1145e6c30be4c0840a0d6e88544d2f927c7c288c2be94e3df61cbe34c37f1f213a1bf0780d
diff --git a/dev-python/django-taggit/django-taggit-3.1.0.ebuild b/dev-python/django-taggit/django-taggit-3.1.0.ebuild
new file mode 100644
index 000000000000..15a22c24a6ea
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="https://github.com/jazzband/django-taggit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings=tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}