summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 18:22:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 18:22:06 +0300
commit88597f8d3eae8b44bb07cdf7ffcf0698d8f37ac2 (patch)
tree0e477921cc1d5bc1218a029a999291d81d017d7c /dev-python/dnspython
parentdev-python/dnspython: Stabilize 2.2.1 ALLARCHES, #838634 (diff)
downloadgentoo-88597f8d3eae8b44bb07cdf7ffcf0698d8f37ac2.tar.gz
gentoo-88597f8d3eae8b44bb07cdf7ffcf0698d8f37ac2.tar.bz2
gentoo-88597f8d3eae8b44bb07cdf7ffcf0698d8f37ac2.zip
dev-python/dnspython: drop 2.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.2.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index e9b8c2585aaf..948cb93bdb3f 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1 @@
-DIST dnspython-2.2.0.tar.gz 303844 BLAKE2B 5a99a06d1c7e8f29e44ddc99fed11d772d83d962d7abde61befb3189c6faa2796b239e9c0ec05a453360986ff4bbbcea929f62017eb3bab2bafa517ae4c02a3b SHA512 0a93bde1ca1081c92b9fb5a02644c4920813f2d0dbe4de1dae736262d53afe41327f3fdd38a10f74ec78f54dd7c7570e37d0adb2b21ab18f9b5cc099fcc6bb85
DIST dnspython-2.2.1.tar.gz 304861 BLAKE2B e6446b91579c6ec0a7266a354ceb58e2f881b55b7376648770ebc2c6104fd815214497516d305b75802e9211703d47a70d66745d872a43afb72f41e55a617652 SHA512 ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb
diff --git a/dev-python/dnspython/dnspython-2.2.0.ebuild b/dev-python/dnspython/dnspython-2.2.0.ebuild
deleted file mode 100644
index 97d64d01ead6..000000000000
--- a/dev-python/dnspython/dnspython-2.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="https://www.dnspython.org/
- https://pypi.org/project/dnspython/"
-SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- <dev-python/idna-4.0[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/network_avail/s:True:False:' \
- tests/*.py || die
- distutils-r1_src_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- epytest -s
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}