summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-05 05:57:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-05 06:18:27 +0100
commit71c8e635c69b655f696c4476451ea5a81f47131d (patch)
tree8df5f0ce10f7421f7a2417d13d87154bd7d16aae /dev-python/environs/environs-11.0.0.ebuild
parentdev-python/marshmallow: Bump to 3.21.1 (diff)
downloadgentoo-71c8e635c69b655f696c4476451ea5a81f47131d.tar.gz
gentoo-71c8e635c69b655f696c4476451ea5a81f47131d.tar.bz2
gentoo-71c8e635c69b655f696c4476451ea5a81f47131d.zip
dev-python/environs: Bump to 11.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/environs/environs-11.0.0.ebuild')
-rw-r--r--dev-python/environs/environs-11.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/environs/environs-11.0.0.ebuild b/dev-python/environs/environs-11.0.0.ebuild
new file mode 100644
index 000000000000..68b7ee41ac19
--- /dev/null
+++ b/dev-python/environs/environs-11.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for simplified environment variable parsing"
+HOMEPAGE="
+ https://github.com/sloria/environs/
+ https://pypi.org/project/environs/
+"
+SRC_URI="
+ https://github.com/sloria/environs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.13.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest