summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:53:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:53:20 +0200
commit342bf150a81f35f2ee2931cae4781416495ac42d (patch)
tree0910824a6cffa6cb132f0865dd98ecf61b08ff41 /dev-python/fitsio
parentdev-python/Faker: Bump to 18.11.2 (diff)
downloadgentoo-342bf150a81f35f2ee2931cae4781416495ac42d.tar.gz
gentoo-342bf150a81f35f2ee2931cae4781416495ac42d.tar.bz2
gentoo-342bf150a81f35f2ee2931cae4781416495ac42d.zip
dev-python/fitsio: Bump to 1.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fitsio')
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/fitsio-1.1.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index 3223a1a87139..692de7d1edad 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1,2 +1,3 @@
+DIST fitsio-1.1.10.gh.tar.gz 5052842 BLAKE2B 1d0fb90fa23b3adf1ab172c89f9475b59d1bc909b225129c923bd27391af2844d4b56134568ed07124b9152000fb1325a2225997048d18aa596246d609888b28 SHA512 d0e28f1892640404a2514832e1d68ac202de4c3d3a840c783e6eb3de381f2180136eaec856bd7ab1b236b67c273417a137121137f6d1e66ee6bb2becdc522fa6
DIST fitsio-1.1.8.gh.tar.gz 5052021 BLAKE2B fd54450ccce61a502b803e85df92821a0f64c91e6c8a535b09da6d6e68df1a0299ffc57e87b514d46f635d83dbabc15dc67a99d84fc93ca11ba052fab9472210 SHA512 8ff7c675d39c74ae821dde29ebbfaa5686a4c8e4454bf6ec4b7edce2f6a2e026aa3fac584af1647e7913748202c8c8e3d58deba9bf07253e3fe4606fd2b52c93
DIST fitsio-1.1.9.gh.tar.gz 5052730 BLAKE2B 4169eed73e825f37bc5f5e6a2b27942b08f14d0e38c8037aa094031cd1b85e60ba3be8499c7d1225e78c093581aafe681177e4acb7da553bda2b0992ea38d6f2 SHA512 9840e9e48a11d454bd02cf19167ba977fa624842172ac538c7d9c5a446fbe0ef6fa7ee146f3878232e5b35570b2eec731e597503346adcfab38a1d0bada2b463
diff --git a/dev-python/fitsio/fitsio-1.1.10.ebuild b/dev-python/fitsio/fitsio-1.1.10.ebuild
new file mode 100644
index 000000000000..aae8b9bbdd5a
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.1.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="
+ https://github.com/esheldon/fitsio/
+ https://pypi.org/project/fitsio/
+"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ use_system_fitsio = True
+ EOF
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}