summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-25 10:20:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-25 10:20:07 +0100
commit730696dea534c1afb2f4dcb74245eeeaa6d73ce4 (patch)
treed98786e6229ea54f598bcd9e7c05b597b08d5ed4 /dev-python/flaky
parentpackage.deprecated: Add dev-python/oauth2client (diff)
downloadgentoo-730696dea534c1afb2f4dcb74245eeeaa6d73ce4.tar.gz
gentoo-730696dea534c1afb2f4dcb74245eeeaa6d73ce4.tar.bz2
gentoo-730696dea534c1afb2f4dcb74245eeeaa6d73ce4.zip
dev-python/flaky: Remove nose plugin
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/flaky-3.7.0-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/flaky/flaky-3.7.0-r3.ebuild b/dev-python/flaky/flaky-3.7.0-r3.ebuild
new file mode 100644
index 000000000000..608bfc37ec70
--- /dev/null
+++ b/dev-python/flaky/flaky-3.7.0-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for pytest that automatically reruns flaky tests"
+HOMEPAGE="
+ https://github.com/box/flaky/
+ https://pypi.org/project/flaky/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ rm flaky/flaky_nose_plugin.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ epytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ epytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}