summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-01 11:37:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-01 11:39:35 +0200
commit0ebeafe5cae26a6599da337f2a79af02904acd84 (patch)
treebaee95c3640e7b6df0acbd1c70bc51742c4bfdec /dev-python/flit/flit-3.3.0.ebuild
parentdev-python/flit_core: Bump to 3.3.0 (diff)
downloadgentoo-0ebeafe5cae26a6599da337f2a79af02904acd84.tar.gz
gentoo-0ebeafe5cae26a6599da337f2a79af02904acd84.tar.bz2
gentoo-0ebeafe5cae26a6599da337f2a79af02904acd84.zip
dev-python/flit: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flit/flit-3.3.0.ebuild')
-rw-r--r--dev-python/flit/flit-3.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/flit/flit-3.3.0.ebuild b/dev-python/flit/flit-3.3.0.ebuild
new file mode 100644
index 000000000000..b7434f5ec52d
--- /dev/null
+++ b/dev-python/flit/flit-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/flit_core-3.3.0[${PYTHON_USEDEP}]
+ dev-python/intreehooks[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ sys-apps/grep
+ sys-apps/findutils
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/flit-3.2.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \