summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-02 20:31:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-02 20:40:29 +0300
commit7e70e93dea9da9132ad5c130a74e00d54e8478ca (patch)
tree9b88a64c8e0b770477eeb90c5b3c5416428c265a /dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
parentdev-python/repoze-sphinx-autointerface: mark ALLARCHES (diff)
downloadgentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.tar.gz
gentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.tar.bz2
gentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.zip
dev-python/flufl-bounce: add 4.0, enable py3.10, enable tests
Closes: https://bugs.gentoo.org/797922 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flufl-bounce/flufl-bounce-4.0.ebuild')
-rw-r--r--dev-python/flufl-bounce/flufl-bounce-4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
new file mode 100644
index 000000000000..fb2312fbbe76
--- /dev/null
+++ b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Email bounce detectors."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.bounce"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}