summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-26 14:35:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-26 14:41:47 +0200
commit46e9fe5f5a4abf2bc999057e2ea94e5f9459b393 (patch)
treee7e84bafcc21ed781785c83b3c12b025e7a261b1 /dev-python/fonttools
parentsys-kernel/gentoo-sources: gpio regression fix (diff)
downloadgentoo-46e9fe5f5a4abf2bc999057e2ea94e5f9459b393.tar.gz
gentoo-46e9fe5f5a4abf2bc999057e2ea94e5f9459b393.tar.bz2
gentoo-46e9fe5f5a4abf2bc999057e2ea94e5f9459b393.zip
dev-python/fonttools: Bump to 4.33.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.33.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 07ed79e7d6be..07910863c4f0 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -5,3 +5,4 @@ DIST fonttools-4.32.0.tar.gz 2966840 BLAKE2B 67a79c8c2e26f9f72fcf6ea4ab5ee3712d3
DIST fonttools-4.33.0.tar.gz 3525052 BLAKE2B 5ea275adbfbf6e01222f6eba8f5eef7afe533b9692e6a7a2fb644fb68dec632ab2962d6b7f6b4ff876676e8314aadbfc04a005ea7a389904e398723feaa756d0 SHA512 147f6d41d1a6b27ebe6973cb91a90384291ad8c7b75b71c3b814908012530066b79f4c39bdd6da9e98614ef61b1cc19803756aba73e4da7ce2e82147390f0023
DIST fonttools-4.33.1.tar.gz 3526591 BLAKE2B c720e9159602168bc2f435f96e9b470e95a748e3e61aac717659e01e5998c8ead825056fe6114cb40be47ab1ebcd7dc6f3152cccd87aec5b49134147694aa3eb SHA512 14e4da0e146d4b88ab6375ad7c912f1ec6f437386e2d676bbffcd5a84be980151ed4f77f69bf618843b321106ca763af564cf05dfb6fa11888f02adfde7d74b2
DIST fonttools-4.33.2.tar.gz 3526700 BLAKE2B faa8db2d5ba80a7cb2cd4fb82045aa821f72d296c3b0994f266c69bc1f38b9c46a24208612d539e3576d75371d95d49d9a103fed8ab7604ebf0df50ec8f25d2f SHA512 dd032f9f8d9167aa8d83137006062a5d293aeb4116cd2b24a9d5d3d750887876214a6b6e9fe54efd569cada64164c76f242b234569d86b45e5f279d6c1a5db95
+DIST fonttools-4.33.3.tar.gz 3526937 BLAKE2B 26539f76ac1919e572633695aca7a95f7f715ef18bd7d36de22e5491124ce36d3907f1e7b167d23685bca437f0bf7cf99159cd918ab2b1a450b716166d30fc37 SHA512 403e19cda46d67dea9f517e58c2e95ed04c53e6832919d85df9db4538431252e5ec4554e22410fd45cba634998de1576cf55d50f56de5ad497a108dcec4ed56a
diff --git a/dev-python/fonttools/fonttools-4.33.3.ebuild b/dev-python/fonttools/fonttools-4.33.3.ebuild
new file mode 100644
index 000000000000..1e5f5a109536
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.33.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}