summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 09:06:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:34:06 +0200
commit9d5fdd1631259191d89fca6b6f263066eda98cd4 (patch)
tree64c9fa910fd89dbbef6e2c8c39cb124de7ccd728 /dev-python/fsspec/fsspec-2021.05.0.ebuild
parentdev-python/asyncstdlib: Bump to 3.9.2 (diff)
downloadgentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.tar.gz
gentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.tar.bz2
gentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.zip
dev-python/fsspec: Bump to 2021.05.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec/fsspec-2021.05.0.ebuild')
-rw-r--r--dev-python/fsspec/fsspec-2021.05.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/fsspec/fsspec-2021.05.0.ebuild b/dev-python/fsspec/fsspec-2021.05.0.ebuild
new file mode 100644
index 000000000000..4032b21e0f99
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.05.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ epytest \
+ --deselect fsspec/tests/test_spec.py::test_find \
+ --ignore fsspec/implementations/tests/test_dbfs.py \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py
+}