summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-02 09:50:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-02 10:28:04 +0200
commit09feb7f7c37c246bfc27c0be5807092e8400149d (patch)
treed23658302f908fa37f097f54e4437a878a0c78af /dev-python/google-auth
parentdev-python/ypy-websocket: Bump to 0.10.0 (diff)
downloadgentoo-09feb7f7c37c246bfc27c0be5807092e8400149d.tar.gz
gentoo-09feb7f7c37c246bfc27c0be5807092e8400149d.tar.bz2
gentoo-09feb7f7c37c246bfc27c0be5807092e8400149d.zip
dev-python/google-auth: Bump to 2.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.19.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 08b835941753..434b3ad4a01e 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -2,3 +2,4 @@ DIST google-auth-2.17.3.tar.gz 222865 BLAKE2B 32b7a483cf458415157057fc92631ca4b8
DIST google-auth-2.18.0.tar.gz 224653 BLAKE2B 56de5ac899bd6f143e1e1481d787627821c4f82cd4cd94597c6dce9753a7ea9605b9647464eb42f37571e2f6cded9cea5c966416bdd6c96b6413e1ef3e2b2efe SHA512 2443c7948cb71803197dba2d57ff92f4c17981fa47ac383e9636d2ed239a7d71f43a4d8f61c7c90c651b8d13a0cfc5633a815d72bd731e92d83f3bbaa1b95118
DIST google-auth-2.18.1.tar.gz 224714 BLAKE2B 2fa63ed18d4dfa4940c93e5f3fb099a6892a16148e5161c3e52980cdee80b7b153a60c005bd3d1d856476f85678b88315d3f4b639f693d292abbf8133dee9397 SHA512 34e53a1c0cf42ab600281d815f259bb252987f163925e357dc2e636c945fd4b74c1f4168bf7d90a6e352fe1d7343767b68bf94fdbb1bc90a92c7067b0e2f2f8f
DIST google-auth-2.19.0.tar.gz 230075 BLAKE2B aa79292c866ff006c240ad3dc0d157b9c8d66c3ee722b328860911bea509f73d4cea5f4fc4597c95f5b6f5f6cc9f793db9d85c6bc8772bc7157e6e2ad566c56e SHA512 3eceb1c0f0797c9ee3eb3e60f56495b81234640bc9da95d43b1a2c817cedbf0588434b8a5de7837433788a5aed42a378582fec2568182f2554bc24ca54c7ab26
+DIST google-auth-2.19.1.tar.gz 230290 BLAKE2B c7f76e1bd936d4d76c81e19fbf6bb50dfe700666d8eb234f762253547fd670d1d26a97a7fe4457bdb719712d32e28e3c8f9adc82c475ee6830f5fd2af994bb3a SHA512 8a8106abb1a0966254caa2e568fe9a9c887601b19e5309f4d43e1b07f3e3280ad358cf8999e34719d6f23473b263d128a2d0321f0ff184c4e188b0b5cf88a6ee
diff --git a/dev-python/google-auth/google-auth-2.19.1.ebuild b/dev-python/google-auth/google-auth-2.19.1.ebuild
new file mode 100644
index 000000000000..c7a6aff8ed05
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.19.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}