summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 19:40:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 19:40:09 +0200
commitdf0f16064256a7b6a4b8dcfcb6c37744b827d42c (patch)
treed9c87d2326c73b1650dcd9fd533ffcb890754626 /dev-python/google-auth
parentdev-python/tekore: Bump to 4.6.1 (diff)
downloadgentoo-df0f16064256a7b6a4b8dcfcb6c37744b827d42c.tar.gz
gentoo-df0f16064256a7b6a4b8dcfcb6c37744b827d42c.tar.bz2
gentoo-df0f16064256a7b6a4b8dcfcb6c37744b827d42c.zip
dev-python/google-auth: Bump to 2.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.19.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 46ca796b2f31..08b835941753 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-2.17.3.tar.gz 222865 BLAKE2B 32b7a483cf458415157057fc92631ca4b822d31505b6b037dce8b9bb210982e4c6164db0b8453e5ef40c9d79c56939efaac74024e60aa95d69f843511e6399d0 SHA512 a731260cdfd74a2a095d682aecde55807727eb24fbc4c0ea0da2fb24a6b0f9eed5653cf9ce18ce2caee2e79a7bcadb7a9342aa511db30358c670afbf01c2fd4c
DIST google-auth-2.18.0.tar.gz 224653 BLAKE2B 56de5ac899bd6f143e1e1481d787627821c4f82cd4cd94597c6dce9753a7ea9605b9647464eb42f37571e2f6cded9cea5c966416bdd6c96b6413e1ef3e2b2efe SHA512 2443c7948cb71803197dba2d57ff92f4c17981fa47ac383e9636d2ed239a7d71f43a4d8f61c7c90c651b8d13a0cfc5633a815d72bd731e92d83f3bbaa1b95118
DIST google-auth-2.18.1.tar.gz 224714 BLAKE2B 2fa63ed18d4dfa4940c93e5f3fb099a6892a16148e5161c3e52980cdee80b7b153a60c005bd3d1d856476f85678b88315d3f4b639f693d292abbf8133dee9397 SHA512 34e53a1c0cf42ab600281d815f259bb252987f163925e357dc2e636c945fd4b74c1f4168bf7d90a6e352fe1d7343767b68bf94fdbb1bc90a92c7067b0e2f2f8f
+DIST google-auth-2.19.0.tar.gz 230075 BLAKE2B aa79292c866ff006c240ad3dc0d157b9c8d66c3ee722b328860911bea509f73d4cea5f4fc4597c95f5b6f5f6cc9f793db9d85c6bc8772bc7157e6e2ad566c56e SHA512 3eceb1c0f0797c9ee3eb3e60f56495b81234640bc9da95d43b1a2c817cedbf0588434b8a5de7837433788a5aed42a378582fec2568182f2554bc24ca54c7ab26
diff --git a/dev-python/google-auth/google-auth-2.19.0.ebuild b/dev-python/google-auth/google-auth-2.19.0.ebuild
new file mode 100644
index 000000000000..c7a6aff8ed05
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.19.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}