summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/hachoir-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/hachoir-core')
-rw-r--r--dev-python/hachoir-core/Manifest1
-rw-r--r--dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild29
-rw-r--r--dev-python/hachoir-core/metadata.xml13
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/hachoir-core/Manifest b/dev-python/hachoir-core/Manifest
new file mode 100644
index 000000000000..d3f79c502f70
--- /dev/null
+++ b/dev-python/hachoir-core/Manifest
@@ -0,0 +1 @@
+DIST hachoir-core-1.3.3.tar.gz 91504 SHA256 ecf5d16eccc76b22071d6062e54edb67595f70d827644d3a6dff04289b4058df SHA512 71c24c4c4612ab544663ddde4aa07bb7514fcb3b86596ad67d6b48e0d8590b1a9d8c88ed4007c2341cb195ef825e06634bce14c62cc2c5200b6d745d341cac51 WHIRLPOOL 1b6ab4088cc5a8270cd590d00fafb0c68571248a5f15703d5e644613cc338c6d594df87b82e2bc39f420333ca34bf37f45e003aedf43e1d085958a9294a716c7
diff --git a/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..26eee5426a19
--- /dev/null
+++ b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-core http://pypi.python.org/pypi/hachoir-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ mydistutilsargs=( --setuptools )
+}
+
+python_test() {
+ "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/hachoir-core/metadata.xml b/dev-python/hachoir-core/metadata.xml
new file mode 100644
index 000000000000..12b9db27479c
--- /dev/null
+++ b/dev-python/hachoir-core/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">A tool written for hackers to cut file or any binary stream. A file is
+ splitted in a tree of fields where the smallest field can be just a bit.
+ There are various field types: integer, string, bits, padding, sub file,
+ etc.</longdescription>
+ <upstream>
+ <remote-id type="pypi">hachoir-core</remote-id>
+ <remote-id type="bitbucket">haypo/hachoir</remote-id>
+ </upstream>
+</pkgmetadata>