summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 08:02:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 08:02:43 +0200
commitd56c131ba526099031104473e13bb335c09679d0 (patch)
treedca5a0f8ffbd8ef2a69fcca0b02e321c7361dd7b /dev-python/hcloud
parentdev-python/pytest-order: Bump to 1.2.1 (diff)
downloadgentoo-d56c131ba526099031104473e13bb335c09679d0.tar.gz
gentoo-d56c131ba526099031104473e13bb335c09679d0.tar.bz2
gentoo-d56c131ba526099031104473e13bb335c09679d0.zip
dev-python/hcloud: Bump to 1.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest1
-rw-r--r--dev-python/hcloud/hcloud-1.35.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 5c6bdc1137bb..78f0908c27ab 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-python-1.33.2.gh.tar.gz 113101 BLAKE2B b544b3722bb4782b6aa6c6b40d2cd0ee46625168cb4cb4645254bf5e2690f3f708a5422d1a8f6e7a2a66801bbaab5e2105c7d3c764c3137a6f7b38871e474e3f SHA512 a2b85bd1f6580bbf359634084d5c247fc69339ee01900567e7d51db03cc295e7fef989ab4663f4cb8be7dd9c527a6172780557e24b6425760fd615067e54496c
DIST hcloud-python-1.34.0.gh.tar.gz 114383 BLAKE2B bc1976205c8d9c6ee92bfaf818052eced54bb871fbb83f794d3a56367964dd060530912879332e13abc7dbf5fa868d0b0350bd1ce05f185d7c0fa6fed75cbcf4 SHA512 813eba0619dbb27671001d9692cfc5034c7345e148ca560ad8379901f88f30bd657ce06e8cf5e5de3ecc4f614335f6dae570d154a6293ea4a3ffa1355adb3f40
+DIST hcloud-python-1.35.0.gh.tar.gz 114672 BLAKE2B 1742d571fccc369245d9bf9c8f85da1c37061a13368dfe928b666e4f514ed5bf9f87f61bc4e5859ec7a759f5dfa6364c60ff851572071b46b2df21c0fe6f02a6 SHA512 48cee279b4f0025c61662304e67b8cee6a718c071f801daac440054439dedb21ab656c244f486860b056edd8bdc9330d3134ec936085297f24442a93cbbcc9e4
diff --git a/dev-python/hcloud/hcloud-1.35.0.ebuild b/dev-python/hcloud/hcloud-1.35.0.ebuild
new file mode 100644
index 000000000000..4d1d123f8d66
--- /dev/null
+++ b/dev-python/hcloud/hcloud-1.35.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}