summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-13 07:01:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-13 07:55:03 +0100
commitd8327e7c73c138f02481ddb1623e2d3260af5509 (patch)
tree16c27d939e48e7fe11d54086eb9d621724d66f84 /dev-python/hypothesis
parentdev-python/cfn-lint: Bump to 1.19.0 (diff)
downloadgentoo-d8327e7c73c138f02481ddb1623e2d3260af5509.tar.gz
gentoo-d8327e7c73c138f02481ddb1623e2d3260af5509.tar.bz2
gentoo-d8327e7c73c138f02481ddb1623e2d3260af5509.zip
dev-python/hypothesis: Bump to 6.118.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.118.8.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 713cc6ee6d81..0461a0516952 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-6.116.0.gh.tar.gz 9480480 BLAKE2B 350abfd8bad65a33669345a71c3df9
DIST hypothesis-6.118.0.gh.tar.gz 9481630 BLAKE2B 691be7d387d61ce7e65b998cebfc11977bc3727537424e8594c6514d6ea9fae532fb203e65a4f014e74db0656946cb2920868c4d211801a1472046640a3bcdaf SHA512 740ebebc297043aed197bd848489661fa7252a1b63933b1abb17085550cc300b0bbc9217261bb2de28c9c1ae0dfda836cd4e325806f52560a1b5935ec6ec7356
DIST hypothesis-6.118.3.gh.tar.gz 9484146 BLAKE2B 2cac4089ba76431588640777a6fea2b2681ca3530ac9d48775174799715b82f5d9f31540c1c4677abae13bf9c84502bbe086e0a76f5c5a650792e6b17c2e4b81 SHA512 9b12c1ba83f4b0ce4e3b1ae6c3c6616d502f44d458a421e7938b1c8a58c20dd1bdfb0b7ed8f1690c795cd0723874becbd06ef8771ef8d8bd36950e1f0d1cabef
DIST hypothesis-6.118.7.gh.tar.gz 9486197 BLAKE2B 1247665e4cc6c10ff6f628f4ef312ce90e1f791ea853a2c22fffec5f57af182e423e97b392535b569fc19889a1e7176905ba6b933e8ca69ae693c8845dd9c89f SHA512 b33a1cdcc56301fde6bd7176caed2c34b43a2a7a5e21590b0fac2cf734332ed9e626f9114f7b6f6c06b67926b5a59649a7de6008a256b7a7655d8acb8b482f0f
+DIST hypothesis-6.118.8.gh.tar.gz 9486191 BLAKE2B daadb191cf8a0a4a972604c9320e7c10b4a342e7a6f240e6fff1a5a5d52fef5d004134381ef475f7e1b7143b38fac15c59538a6a8cac48433bd62c760db2cd67 SHA512 b5d240f81596d742002ebe073d086f149af17dafabbc9c070f6e109aca05f506c4291a10a36f6a799fd8fe20285bab8f6776685f29a6e505225ffcc581d44d64
diff --git a/dev-python/hypothesis/hypothesis-6.118.8.ebuild b/dev-python/hypothesis/hypothesis-6.118.8.ebuild
new file mode 100644
index 000000000000..f3d89f9d71ea
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.118.8.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}