summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 06:53:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-27 07:32:49 +0200
commitbdda1e59b649a0718c513cbe75c7d915cbc7b9d5 (patch)
tree7f6e135fb7d93c014bb63ea3d1e40970ff63b19f /dev-python/icalendar
parentdev-python/dask: Bump to 2023.5.1 (diff)
downloadgentoo-bdda1e59b649a0718c513cbe75c7d915cbc7b9d5.tar.gz
gentoo-bdda1e59b649a0718c513cbe75c7d915cbc7b9d5.tar.bz2
gentoo-bdda1e59b649a0718c513cbe75c7d915cbc7b9d5.zip
dev-python/icalendar: Bump to 5.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index c7ab30fd42c9..ccde9b6a34d1 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-5.0.5.tar.gz 103204 BLAKE2B 20887b535f595ab222f3aca8ac396a71b53975816663693f89277a03be41885780d0b15269cd5955e00eeda0867db46781ea2300f542bca1a18687d50e025989 SHA512 1c1e6c94e2caa07686bc12389c3a5b823478f1652695bc167af95c26f92bbd3d60fb4e540d74eb90db289c647bfd6e1c82e83ee8f89bc87b80100d8b6fe5dd90
+DIST icalendar-5.0.6.tar.gz 103352 BLAKE2B 642d5adace1358001f3691697443824a39347ab86cab2643f428e64cc47f1c231ed501b6d4fabe21a357ce357ed951467d41ccdbbce70bbe666b8aeda1c19e67 SHA512 696240e7e4efe57a194be5fa0e6158284e297277e72f7aea0bc547db5f638dae05ca8cafcadedb43673f1d9f19241f25516d90e8247a79660d8b2ef71c5da11a
diff --git a/dev-python/icalendar/icalendar-5.0.6.ebuild b/dev-python/icalendar/icalendar-5.0.6.ebuild
new file mode 100644
index 000000000000..8c55d51ef344
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}