summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:23:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:27 +0100
commit5b7e3cfcc170439092ac9349c896a635e714caa4 (patch)
treed3cde81f56198c915e0c9edf5bc384e4a6dbe982 /dev-python/imageio
parentdev-python/imageio: Remove old (diff)
downloadgentoo-5b7e3cfcc170439092ac9349c896a635e714caa4.tar.gz
gentoo-5b7e3cfcc170439092ac9349c896a635e714caa4.tar.bz2
gentoo-5b7e3cfcc170439092ac9349c896a635e714caa4.zip
dev-python/imageio: Bump to 2.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.16.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index f13cae32333c..c5d58cdb787e 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.16.0.gh.tar.gz 360333 BLAKE2B fbfea25b9a6dfb945bcaced141649bcc3a7c578115fe2be3151d7a90bab6a51fc20e4806085a2afc934b7ec9de95b5df9fedba9af9722242dac44e2f86009e2b SHA512 18f6e3f0b5c09ac546640ef88a0fe6c157e20ecbaa2de5a2199eab6caac3ca9fd294cf66a2eea79b954271c27390816392af62a27d0e2e11817776efec3a0cd3
+DIST imageio-2.16.1.gh.tar.gz 361506 BLAKE2B df7df1cdf414fa762a37c509f2452f7ef20b811695b71acd391d6f565161ae4b5d1caa9dc2f9278ddb87ad518087ed2c729b93806cf1f01a7402e7a77af9383f SHA512 8cd5ce184f67be9cd5edbd5bf51f59c271a71e8fe68c22d284ddabe24cdec6bcf5e590c9c95664b0205509c133e9cd959d11605226a1d4d99f14e95c6d7527c3
diff --git a/dev-python/imageio/imageio-2.16.1.ebuild b/dev-python/imageio/imageio-2.16.1.ebuild
new file mode 100644
index 000000000000..4a1ac91da053
--- /dev/null
+++ b/dev-python/imageio/imageio-2.16.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)
+
+EPYTEST_IGNORE=(
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+)