summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-19 22:54:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-19 22:56:41 +0200
commit61bdb2c2f31689a3b968aa09143baf654fec4574 (patch)
tree4e98eac44e733ca0849075eb57dd0a8dc4a18bfe /dev-python/immutables
parentdev-python/aiocontextvars: Port to py3.9 (diff)
downloadgentoo-61bdb2c2f31689a3b968aa09143baf654fec4574.tar.gz
gentoo-61bdb2c2f31689a3b968aa09143baf654fec4574.tar.bz2
gentoo-61bdb2c2f31689a3b968aa09143baf654fec4574.zip
dev-python/immutables: Bump to 0.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/immutables')
-rw-r--r--dev-python/immutables/Manifest1
-rw-r--r--dev-python/immutables/immutables-0.14.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 2577c0f13d16..8f1838421886 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1 +1,2 @@
DIST immutables-0.11.tar.gz 76589 BLAKE2B 64d7ac89dfe680d1fe78704c165a1fbb15559203980f1a8edd65fbd74589bf2038c799037189849a917555a67483e0cb352664b1d44f3ce161db6c88b878ae5a SHA512 fceb1feb5fd8de4444681cb89c6692206042d0f8f404d78848c379ca3afbb07425e2ba875f7b7cdb42bf126ea0b9f682c0b873c4867c5266cc77da28d29f6ab5
+DIST immutables-0.14.tar.gz 79451 BLAKE2B b18b554536a92b6f23e4c8366161cd43c2bd75d81fc619bfc9760b265835c7fc729c797758f195bd50f81573c4c52d48449deabf19167321eabbbfdfd8961217 SHA512 244a1faab70d46333749abcc2a98f65802c656eb58b23353893a8d894aff4089ccf9ed43170aa0094d8ec2d59a0dc7014d8bf12ad1a044fc066b43ae968968ea
diff --git a/dev-python/immutables/immutables-0.14.ebuild b/dev-python/immutables/immutables-0.14.ebuild
new file mode 100644
index 000000000000..ce13a1de3ff4
--- /dev/null
+++ b/dev-python/immutables/immutables-0.14.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest