summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-30 14:07:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-30 15:22:56 +0200
commitac1df1b75f8e3a099f64b3c5ac25e24d9cc22b3c (patch)
tree4ef12dd6a81eb2d35793d5295d2e81535e51d686 /dev-python/indexed-gzip
parentdev-python/indexed-gzip: Control line tracing via USE=debug (diff)
downloadgentoo-ac1df1b75f8e3a099f64b3c5ac25e24d9cc22b3c.tar.gz
gentoo-ac1df1b75f8e3a099f64b3c5ac25e24d9cc22b3c.tar.bz2
gentoo-ac1df1b75f8e3a099f64b3c5ac25e24d9cc22b3c.zip
dev-python/indexed-gzip: Fix implicit dep on dev-python/numpy
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed-gzip')
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
index 1623c5ba6d3c..f0471dab64aa 100644
--- a/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
+++ b/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
@@ -48,6 +48,14 @@ src_compile() {
if use debug; then
export INDEXED_GZIP_TESTING=1
fi
+ # Fix implicit dependency on numpy that is used to build test
+ # extensions.
+ if ! use test; then
+ local -x PYTHONPATH="${T}:${PYTHONPATH}"
+ cat >> "${T}"/numpy.py <<-EOF || die
+ raise ImportError("I am not here!")
+ EOF
+ fi
distutils-r1_src_compile
}