summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 10:15:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 12:36:26 +0200
commit4213f8ddf83760f3d37d9d3143bc22babb704f8f (patch)
tree280f754067f653f82d642f2d081687bbddf33e68 /dev-python/ipython
parentdev-python/ipywidgets: Remove old (diff)
downloadgentoo-4213f8ddf83760f3d37d9d3143bc22babb704f8f.tar.gz
gentoo-4213f8ddf83760f3d37d9d3143bc22babb704f8f.tar.bz2
gentoo-4213f8ddf83760f3d37d9d3143bc22babb704f8f.zip
dev-python/ipython: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ipython-8.26.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/ipython/ipython-8.26.0.ebuild b/dev-python/ipython/ipython-8.26.0.ebuild
index c5cb7a5fe775..b492448b16c1 100644
--- a/dev-python/ipython/ipython-8.26.0.ebuild
+++ b/dev-python/ipython/ipython-8.26.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE='readline(+),sqlite,threads(+)'
inherit distutils-r1 optfeature pypi virtualx
@@ -66,13 +66,15 @@ RDEPEND+="
"
PDEPEND="
$(python_gen_cond_dep '
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ ' 'python*')
+ $(python_gen_cond_dep '
notebook? (
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/ipywidgets[${PYTHON_USEDEP}]
dev-python/widgetsnbextension[${PYTHON_USEDEP}]
)
- qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
- ' 'python*')
+ ' 3.{10..12})
smp? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
>=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
@@ -107,6 +109,12 @@ python_test() {
IPython/lib/tests/test_display.py::TestAudioDataWithoutNumpy
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring mismatch?
+ IPython/core/tests/test_debugger.py::IPython.core.tests.test_debugger.test_ipdb_magics
+ )
+ ;;
esac
# nonfatal implied by virtx