summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:02:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 01:23:54 +0100
commite56fe73e14a05236624ec13d310cb326cd077cde (patch)
tree0131f1a6a7795b48a3ff5a8a120830aa35ad9016 /dev-python/ipython
parentdev-python/liblarch: Run a single Xvfb (diff)
downloadgentoo-e56fe73e14a05236624ec13d310cb326cd077cde.tar.gz
gentoo-e56fe73e14a05236624ec13d310cb326cd077cde.tar.bz2
gentoo-e56fe73e14a05236624ec13d310cb326cd077cde.zip
dev-python/ipython: Run a single Xvfb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ipython-8.0.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/ipython/ipython-8.0.1.ebuild b/dev-python/ipython/ipython-8.0.1.ebuild
index a1b847bc2132..3354470b2300 100644
--- a/dev-python/ipython/ipython-8.0.1.ebuild
+++ b/dev-python/ipython/ipython-8.0.1.ebuild
@@ -99,6 +99,10 @@ python_compile_all() {
fi
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
local -x IPYTHON_TESTING_TIMEOUT_SCALE=20
local EPYTEST_DESELECT=(
@@ -113,7 +117,7 @@ python_test() {
IPython/core/tests/test_completer.py::TestCompleter::test_all_completions_dups
IPython/core/tests/test_completer.py::TestCompleter::test_deduplicate_completions
)
- virtx epytest
+ epytest || die "Tests failed with ${EPYTHON}"
}
python_install() {