summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 16:08:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 16:31:50 +0200
commitdaf8e4d1d589a23f61e597854a60e1c2a8866eb5 (patch)
tree57b57e9de3fdc3941b5dec0020c19244549be27d /dev-python/isoduration/isoduration-20.11.0-r1.ebuild
parentdev-python/arrow: Enable py3.11 (diff)
downloadgentoo-daf8e4d1d589a23f61e597854a60e1c2a8866eb5.tar.gz
gentoo-daf8e4d1d589a23f61e597854a60e1c2a8866eb5.tar.bz2
gentoo-daf8e4d1d589a23f61e597854a60e1c2a8866eb5.zip
dev-python/isoduration: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isoduration/isoduration-20.11.0-r1.ebuild')
-rw-r--r--dev-python/isoduration/isoduration-20.11.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/isoduration/isoduration-20.11.0-r1.ebuild b/dev-python/isoduration/isoduration-20.11.0-r1.ebuild
new file mode 100644
index 000000000000..723167de104a
--- /dev/null
+++ b/dev-python/isoduration/isoduration-20.11.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Operations with ISO 8601 durations"
+HOMEPAGE="
+ https://pypi.org/project/isoduration/
+ https://github.com/bolsote/isoduration/
+"
+SRC_URI="
+ https://github.com/bolsote/isoduration/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/arrow-0.15.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmark.py
+)