summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-03 22:33:53 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-09-04 09:27:06 -0400
commit9a3b6c82fa3bc70bcb1b057a94d93d5f6f3953a4 (patch)
tree1c0718be0b268b5b19619627f576b0cae6ffb0e6 /dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild
parentdev-libs/libaio: remove unused patches (diff)
downloadgentoo-9a3b6c82fa3bc70bcb1b057a94d93d5f6f3953a4.tar.gz
gentoo-9a3b6c82fa3bc70bcb1b057a94d93d5f6f3953a4.tar.bz2
gentoo-9a3b6c82fa3bc70bcb1b057a94d93d5f6f3953a4.zip
dev-python/jaraco-itertools: bump to 2.0, add changelog
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild')
-rw-r--r--dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild b/dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild
new file mode 100644
index 000000000000..805f91733a88
--- /dev/null
+++ b/dev-python/jaraco-itertools/jaraco-itertools-2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.itertools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}