summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jaraco-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jaraco-utils')
-rw-r--r--dev-python/jaraco-utils/Manifest1
-rw-r--r--dev-python/jaraco-utils/jaraco-utils-10.0.2.ebuild32
-rw-r--r--dev-python/jaraco-utils/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jaraco-utils/Manifest b/dev-python/jaraco-utils/Manifest
new file mode 100644
index 000000000000..f4d1a14ca9a6
--- /dev/null
+++ b/dev-python/jaraco-utils/Manifest
@@ -0,0 +1 @@
+DIST jaraco.util-10.0.2.zip 83375 SHA256 da136010c98f1ceaaa02ab1a201da45d3b2d59348fac8e3c7b1ddb61825ca872 SHA512 9522d0923db0637b605a11014104fbf6d86fc014fa1d065610df0cf8fe18dc5f962c8f4e4a3822c9223b434fbd252a99ac1949e52f7c9774642244f7a25e12e1 WHIRLPOOL 5dc4bdcf744e0fda210a3f1b5de6f5c8ff73c179586873b28cab309f320c662591442c63ae3cbdd2b3187ab56bb9d541839e40525baf1b15d79719015ebf20bc
diff --git a/dev-python/jaraco-utils/jaraco-utils-10.0.2.ebuild b/dev-python/jaraco-utils/jaraco-utils-10.0.2.ebuild
new file mode 100644
index 000000000000..623b881956b7
--- /dev/null
+++ b/dev-python/jaraco-utils/jaraco-utils-10.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="jaraco.util"
+DESCRIPTION="General utility modules that supply commonly-used functionality"
+HOMEPAGE="http://pypi.python.org/pypi/jaraco.util"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/hgtools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )
+ "
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-utils/metadata.xml b/dev-python/jaraco-utils/metadata.xml
new file mode 100644
index 000000000000..f4ade42c4e56
--- /dev/null
+++ b/dev-python/jaraco-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">jaraco.utils</remote-id>
+ </upstream>
+</pkgmetadata>