summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-24 03:26:40 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-07-24 16:28:12 +0200
commit561d2af41a1662af7b81bedefc55a3f2e7f2ff70 (patch)
treef15d602614d4d38370ce68075025927543e2aec8 /dev-python/jpype/jpype-0.6.2.ebuild
parentwww-client/seamonkey: De-uglify new enigmail code a bit. (diff)
downloadgentoo-561d2af41a1662af7b81bedefc55a3f2e7f2ff70.tar.gz
gentoo-561d2af41a1662af7b81bedefc55a3f2e7f2ff70.tar.bz2
gentoo-561d2af41a1662af7b81bedefc55a3f2e7f2ff70.zip
dev-python/jpype: fix building with -Werror=terminate using GCC-6.
Gentoo-Bug: https://bugs.gentoo.org/608920 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5194
Diffstat (limited to 'dev-python/jpype/jpype-0.6.2.ebuild')
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
index 3ea7f1fefbc3..f8dfefc0dd22 100644
--- a/dev-python/jpype/jpype-0.6.2.ebuild
+++ b/dev-python/jpype/jpype-0.6.2.ebuild
@@ -22,6 +22,8 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=virtual/jdk-1.6"
+PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
+
python_compile() {
if ! python_is_python3; then
local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"