summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-07-25 08:01:31 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-25 20:38:45 +0200
commit9af6b55d10170b56ac6b5c29f14fdebe37990d56 (patch)
treefe134381d4e4e7d052575b065520cceb37c61089 /dev-python/jupyter_client/jupyter_client-4.3.0.ebuild
parentdev-python/ipywidgets: Version bump to 5.2.2 (diff)
downloadgentoo-9af6b55d10170b56ac6b5c29f14fdebe37990d56.tar.gz
gentoo-9af6b55d10170b56ac6b5c29f14fdebe37990d56.tar.bz2
gentoo-9af6b55d10170b56ac6b5c29f14fdebe37990d56.zip
dev-python/jupyter_client: Version bump to 4.3.0; Shorten python_test()
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1960 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-4.3.0.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-4.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-4.3.0.ebuild b/dev-python/jupyter_client/jupyter_client-4.3.0.ebuild
new file mode 100644
index 000000000000..7a815b2ea68d
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-4.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package jupyter_client jupyter_client || die
+}