summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-30 23:23:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-30 23:41:50 +0200
commit400077cc3dbf185b520506c8c3f1a8f80668ecbb (patch)
treeb6ed6da6b0f164dec30a5013117ac8ddf1b250ed /dev-python/jupyter_client
parentdev-python/zeroconf: Bump to 0.36.2 (diff)
downloadgentoo-400077cc3dbf185b520506c8c3f1a8f80668ecbb.tar.gz
gentoo-400077cc3dbf185b520506c8c3f1a8f80668ecbb.tar.bz2
gentoo-400077cc3dbf185b520506c8c3f1a8f80668ecbb.zip
dev-python/jupyter_client: Bump to 7.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.0.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index af17171e1111..23169f861290 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-6.1.12.tar.gz 301499 BLAKE2B 8041b84ad2e89413ee60d1aee2e49a67a89b5aad1c3118c8fa7d7d719c8ec2acbc72278c9aaea095cdcb89235800d09b1792b2138c09a4aad59ceaaf695af431 SHA512 f31ff1a24b264c32d35d07491785e1d77935cdb463243e90e4aadcb0a093a074cdce75f01662591766588f39b146077639ca697f71157309dc92f12ae04d5cdd
DIST jupyter_client-7.0.1.tar.gz 317467 BLAKE2B bcaa4f58071e0c90e81afb010a10ad221793a186aba0e7ae233538c810b787e3a0bc734735cd20750500c9d74d6c5f548f7deaf3daa3e989d75b5f9cbb5344ee SHA512 5665018294e87b0ae0fe58a7281e205e1668c3676f7092128f4c6ce8eb13e53983fc888508e913085beb29b13b1aa46307c4bf1c8c25bfe1f9efcfb7254bdf3a
+DIST jupyter_client-7.0.2.tar.gz 317686 BLAKE2B f837d60c1013d6f7db7185112820bc40fe55707403dd179c72c93d7f5a9c752436b8454e0ffb0a133c77a4a11e87ea310d86706145d0501a0ed83d36652cc278 SHA512 24684df13947077add0931fe9e8a2c2b629db120c1554123f36b7c9e736f502f9553c63813de93ff84733eb4a47eb0f5dd48961e3c18527fbd8fece23fbe6440
diff --git a/dev-python/jupyter_client/jupyter_client-7.0.2.ebuild b/dev-python/jupyter_client/jupyter_client-7.0.2.ebuild
new file mode 100644
index 000000000000..e190dd1ddc2d
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.1[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_signal_kernel_subprocesses
+ jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_async_signal_kernel_subprocesses
+ )
+ epytest ${deselect[@]/#/--deselect }
+}