summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-02 08:45:37 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-02 11:59:12 +0100
commit37802d7a2824a04ae29c61aa40504131300d6f1c (patch)
tree1aef54f772319d2266e98ec0f9f6af59b9955418 /dev-python/keyring
parentdev-java/icu4j: removed obsolete 54.1.1-r1 (diff)
downloadgentoo-37802d7a2824a04ae29c61aa40504131300d6f1c.tar.gz
gentoo-37802d7a2824a04ae29c61aa40504131300d6f1c.tar.bz2
gentoo-37802d7a2824a04ae29c61aa40504131300d6f1c.zip
dev-python/keyring: Bump to 23.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-23.5.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 7f5ec820eb14..eff4b611b586 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-23.4.0.tar.gz 44557 BLAKE2B 1115ecfca9f7d7cd5d28168d9d4198e329217ace82a32fe4db1b40aa96e6a352face46f4e8877407618e701713a8f1347810a24706bbe1872bff758f71ae34f5 SHA512 214041375a1bddda099042168f0f4c5ea4cf24c347a0693ab3efd7eb7a0ab2c36abff33f3d83168cfe5ae5dd971e0f3de4548fb0651e435009766aec740e64eb
+DIST keyring-23.5.0.tar.gz 44586 BLAKE2B 70179f8353147679f03c888b1af00d2461264e7a7062eb7b1372615ae883f43352999ce57e24f3378ac66d5e74a81df66702bf380eb32d6d3554777e9ca63dfe SHA512 639d1cdece5dac854053818f3a4751b30fb9f13a2b3abb0090ba0cb519b50604858673678fe6205c2ec10be863e5f3d63cc7891424beabe2482d35b820a60da1
diff --git a/dev-python/keyring/keyring-23.5.0.ebuild b/dev-python/keyring/keyring-23.5.0.ebuild
new file mode 100644
index 000000000000..509006168d2e
--- /dev/null
+++ b/dev-python/keyring/keyring-23.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)