summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 07:51:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:25 +0100
commit707f33610ce7dfe39c5a3ca46f2101d990d9f715 (patch)
tree7206c20e94bbf0c12b2c5237df3999f1e6175e6e /dev-python/keystoneauth1
parentdev-python/python-dbusmock: Bump to 0.31.1 (diff)
downloadgentoo-707f33610ce7dfe39c5a3ca46f2101d990d9f715.tar.gz
gentoo-707f33610ce7dfe39c5a3ca46f2101d990d9f715.tar.bz2
gentoo-707f33610ce7dfe39c5a3ca46f2101d990d9f715.zip
dev-python/keystoneauth1: Bump to 5.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.6.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index fc2f6241f55e..fe5c880dd305 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.5.0.tar.gz 275504 BLAKE2B d40d3d50efefa4d6617ed623ceacd041d3fbd58824fd3bd15c8f6c323daa897733db388985f0ef09f63e152ae06df292e1d2ffd93a0493f2744b7b3e309186a9 SHA512 161ed8967d322346ee2130300ff67c27f7a7bc412757bf5df404c2211747a8d683413ca0f695b9e66b84d78be5624a320091250e9c5f91b9040773785e89b334
+DIST keystoneauth1-5.6.0.tar.gz 275560 BLAKE2B 394c32973ef2b1592263bc1b37fe51c63417ec955d3b2f4e330ff2fe3ebc45e389c5e8e1d7707153b0dc2c5d12050894994292e28c295deb44a972431e8aaf18 SHA512 cb80fd5f804ea2f1152a99a8935ea31e305e693bd6095560d8fb1f3a0b60cdd8c167609818b43b8ea52c34ebd443202ca5dc391f4e67d82a04731216f504fd87
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.6.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.6.0.ebuild
new file mode 100644
index 000000000000..520cf301a0bb
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile to test runner name
+ keystoneauth1/tests/unit/test_session.py::SessionTests::test_user_agent
+ # broken betamax
+ keystoneauth1/tests/unit/test_betamax_fixture.py::TestBetamaxFixture::test_keystoneauth_betamax_fixture
+)
+
+EPYTEST_IGNORE=(
+ # require hacking
+ keystoneauth1/tests/unit/test_hacking_checks.py
+)