summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-28 11:04:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-28 12:14:28 +0200
commit7aba7a52552268f29354fb85d9a3e50965febad5 (patch)
treec734ea44df6d556c149a87818c328314af248e48 /dev-python/kiwisolver
parentdev-python/autobahn: Bump to 22.3.2 (diff)
downloadgentoo-7aba7a52552268f29354fb85d9a3e50965febad5.tar.gz
gentoo-7aba7a52552268f29354fb85d9a3e50965febad5.tar.bz2
gentoo-7aba7a52552268f29354fb85d9a3e50965febad5.zip
dev-python/kiwisolver: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.4.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index d717816c7219..3ff92de50951 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1,2 +1,3 @@
DIST kiwi-1.4.0.tar.gz 92361 BLAKE2B 773da71557d4c9fcd7778fa1771a1c52d0ca6aa4d698a33467a5a3fac8fd4bd3135aec9e836c96c4c18b2873e17743ce5cbc79c5dd1ea189f28adadcf2030e51 SHA512 6f69e232d5620be5f316d273066a1f8a78ebbef2dd8ee1ba56a2a57581fcc0c985fb0a51e6cca8436bcfeb51c4a95a865cde408c497bdec9c7e025f030744f54
+DIST kiwi-1.4.1.tar.gz 91319 BLAKE2B ac8d9cf1e8960f436566e2ff8d589ff6707fc4458299bc33ff96387c36246d583e67ef84610b710b3d9364d8a4ae963577b4abfc3ddbfc18a417f956512479d9 SHA512 7178f26c96ebf4a173b563bc95d2a07a9f75b618fc953aa0d45a8c2719cf868e4409ad2c95280704ee593fc99d9e2c83b0628940b3571d1be712241464a9cd6d
DIST kiwisolver-1.3.2.tar.gz 89075 BLAKE2B 729880e3b18ac8c6c3e48d2fb32f00b4232118eb753f60837c7736c75a0f22e7a259aec46b76bc91286541847929eb4a92fcf9991650dea16d263f4d16beffc1 SHA512 e9ef20756df587b49f7b8e52ff388db6e2e551548ae7d60b6916586fb35249b10bda895a7be7635b300e6100ec1c7daf7d641de6d26d9b2c36055ac6c176302b
diff --git a/dev-python/kiwisolver/kiwisolver-1.4.1.ebuild b/dev-python/kiwisolver/kiwisolver-1.4.1.ebuild
new file mode 100644
index 000000000000..aa5a5cacb378
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=kiwi-${PV}
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi/"
+SRC_URI="
+ https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cppy-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}