summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-09 19:52:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-09 21:30:44 +0300
commit036cf9efc97842642358158dfa0931f6d0043810 (patch)
treec228fc08a53ab287ad7e352153ed990652d890ca /dev-python/lazr-delegates
parentdev-python/namespace-lazr: create new namespace (diff)
downloadgentoo-036cf9efc97842642358158dfa0931f6d0043810.tar.gz
gentoo-036cf9efc97842642358158dfa0931f6d0043810.tar.bz2
gentoo-036cf9efc97842642358158dfa0931f6d0043810.zip
dev-python/lazr-delegates: enable py3.10, EAPI=8, fix pth file install
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/lazr-delegates')
-rw-r--r--dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
index c85bce4ae891..1a1b0145b04b 100644
--- a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
+++ b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,8 +20,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/namespace-lazr[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}