summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 19:55:27 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 19:56:48 +0100
commit79f94fa9a2510b5ad92b0fb726051c215321e9e7 (patch)
tree18fd5bffed6b4fb9528cabf6001814cecb28aaad /dev-python/line_profiler
parentdev-python/platformdirs: Bump to 2.5.4 (diff)
downloadgentoo-79f94fa9a2510b5ad92b0fb726051c215321e9e7.tar.gz
gentoo-79f94fa9a2510b5ad92b0fb726051c215321e9e7.tar.bz2
gentoo-79f94fa9a2510b5ad92b0fb726051c215321e9e7.zip
dev-python/line_profiler: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-4.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 131d8cf98b8a..87ec918af0f4 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-3.5.1.gh.tar.gz 51241 BLAKE2B a3f3cceab9d34062a0b96ce772941bb945f96f7e88f59bb72d08a09fb96db3d9354ce33b0c0088065df5aeb7349c7da37d8697654d9f5130d8bd0b7997306d13 SHA512 4618e57e52b7d7d5ece034735a4ce38dd3a8af57e5b897790be4c8e1ee1757d822d7c1bb76d3c7248432c49c13708bffb9bebbbbf61442de98c5a6ec657cbd57
+DIST line_profiler-4.0.0.gh.tar.gz 62856 BLAKE2B 7beb4b63c016d180d1e7e39b0461759593d3ba3ad1c5150b3623890ece3a69ebb65d48f59e8dc3865a19565ab46f2dc8a2a86698abe890d9bd857e1080cbb557 SHA512 d10b9470c686da863c340da7d4af8b6c6b6cb715486a00af1e1d79686c26909b289b8400a4d526520ade6fbbcd58e868a97603345682d5060a9b3ae2fd3495be
diff --git a/dev-python/line_profiler/line_profiler-4.0.0.ebuild b/dev-python/line_profiler/line_profiler-4.0.0.ebuild
new file mode 100644
index 000000000000..878292de2d8d
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-4.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest
+}