summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 07:06:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 07:06:16 +0100
commitcf7ca17afb77950bf11213b94eeabd726715fe6e (patch)
treee6c4701ae8bd49d65687ab61df844d6becee8c35 /dev-python/line_profiler
parentdev-python/black: Bump to 22.12.0 (diff)
downloadgentoo-cf7ca17afb77950bf11213b94eeabd726715fe6e.tar.gz
gentoo-cf7ca17afb77950bf11213b94eeabd726715fe6e.tar.bz2
gentoo-cf7ca17afb77950bf11213b94eeabd726715fe6e.zip
dev-python/line_profiler: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-4.0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 9241f90555b7..5a10048fcd1d 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,2 +1,3 @@
DIST line_profiler-4.0.0.gh.tar.gz 62856 BLAKE2B 7beb4b63c016d180d1e7e39b0461759593d3ba3ad1c5150b3623890ece3a69ebb65d48f59e8dc3865a19565ab46f2dc8a2a86698abe890d9bd857e1080cbb557 SHA512 d10b9470c686da863c340da7d4af8b6c6b6cb715486a00af1e1d79686c26909b289b8400a4d526520ade6fbbcd58e868a97603345682d5060a9b3ae2fd3495be
DIST line_profiler-4.0.1.gh.tar.gz 63735 BLAKE2B 980298c2f0e2cffac12c1bb8dc87ca7876ac74969aafa77500aeb4ab1ab12e98ca56a2974d1311d560fdd7ff707fe6bb44d010f315a1070dc68accdede9041e9 SHA512 1943b359bc442fff8c35674c6e0ea108cbfb06706ed95dfe961daea5de8797ec01e70a712663fff0dcc727c954ddb8a4da4b45774817b14b903901f9cfe108c6
+DIST line_profiler-4.0.2.gh.tar.gz 63855 BLAKE2B e2f077214fb1387504446882396b3b48f5dc309b9de9ff7d7f39dfb96361e0b4ce5461510c878caabbfa4c2723fe65f2eeca5eb4fb261f1a735ebe32beb3b0fe SHA512 ef07d51a33cc71de0409f8dbdae47c738a8088ece577b077e9b7ff6e4f296da30f7843ef01f3bdcedadc1ad778fe625c0880e6a27844f49cda780f2fd6960acf
diff --git a/dev-python/line_profiler/line_profiler-4.0.2.ebuild b/dev-python/line_profiler/line_profiler-4.0.2.ebuild
new file mode 100644
index 000000000000..878292de2d8d
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-4.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest
+}