summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 00:43:14 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-13 00:47:16 -0600
commit855a9290816bfd44acfdc6d6b87924a58c5a686d (patch)
treea539d225445d239cbdbe2669f6a5357c77359c15 /dev-python/llfuse/files
parentdev-python/dugong: update HOMEPAGE and metadata (diff)
downloadgentoo-855a9290816bfd44acfdc6d6b87924a58c5a686d.tar.gz
gentoo-855a9290816bfd44acfdc6d6b87924a58c5a686d.tar.bz2
gentoo-855a9290816bfd44acfdc6d6b87924a58c5a686d.zip
dev-python/llfuse: version bump to 1.3.5
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/llfuse/files')
-rw-r--r--dev-python/llfuse/files/llfuse-1.3.5-cflags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/llfuse/files/llfuse-1.3.5-cflags.patch b/dev-python/llfuse/files/llfuse-1.3.5-cflags.patch
new file mode 100644
index 000000000000..43490cf5f4db
--- /dev/null
+++ b/dev-python/llfuse/files/llfuse-1.3.5-cflags.patch
@@ -0,0 +1,15 @@
+Build fails under pypy(3) when enabling these flags.
+
+--- llfuse-1.3.5/setup.py
++++ llfuse-1.3.5/setup.py
+@@ -74,8 +74,8 @@
+ long_desc = fh.read()
+
+ compile_args = pkg_config('fuse', cflags=True, ldflags=False, min_ver='2.8.0')
+- compile_args += ['-DFUSE_USE_VERSION=29', '-Wall', '-Wextra', '-Wconversion',
+- '-Wsign-compare', '-DLLFUSE_VERSION="%s"' % LLFUSE_VERSION]
++ compile_args += ['-DFUSE_USE_VERSION=29', '-Wall', '-Wextra',
++ '-DLLFUSE_VERSION="%s"' % LLFUSE_VERSION]
+
+ # We may have unused functions if we compile for older FUSE versions
+ compile_args.append('-Wno-unused-function')