summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-05-24 16:59:09 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-05-24 17:03:19 -0500
commitf9d398f785276139faeb3634135792bfc18e87ab (patch)
tree07c81ae69e59a043dbc439378adc5eec1519f4de /dev-python/magic-wormhole
parentdev-python/txtorcon: new package, add 23.5.0 (diff)
downloadgentoo-f9d398f785276139faeb3634135792bfc18e87ab.tar.gz
gentoo-f9d398f785276139faeb3634135792bfc18e87ab.tar.bz2
gentoo-f9d398f785276139faeb3634135792bfc18e87ab.zip
dev-python/magic-wormhole: new package, add 0.12.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest1
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild31
-rw-r--r--dev-python/magic-wormhole/metadata.xml13
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
new file mode 100644
index 000000000000..c437a0bbd540
--- /dev/null
+++ b/dev-python/magic-wormhole/Manifest
@@ -0,0 +1 @@
+DIST magic-wormhole-0.12.0.tar.gz 274063 BLAKE2B 6a0cddd285169373926de9da26125b34457c76e456b1bfd910baed74090900a663435b0df78e5521fd91274b111d8fad56e923832cdd430b2eb27c31d8b510e3 SHA512 141244e746b0718f2c9417e8f7de6a714b0feb051aea8c7950ea0d1bc5d2e24e922bed29544fe76aa61b06aa2ce2b5f330824017af8c6030813415e6c004c716
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild
new file mode 100644
index 000000000000..d6a97bafd884
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="https://magic-wormhole.readthedocs.io/en/latest/ https://pypi.org/project/magic-wormhole/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]"
diff --git a/dev-python/magic-wormhole/metadata.xml b/dev-python/magic-wormhole/metadata.xml
new file mode 100644
index 000000000000..c0b4cfe14855
--- /dev/null
+++ b/dev-python/magic-wormhole/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">magic-wormhole</remote-id>
+ <remote-id type="github">magic-wormhole/magic-wormhole</remote-id>
+ </upstream>
+</pkgmetadata>