summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:46:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:15 +0100
commit8c27d9298f422c08ac17794706bc2ca78c0cee6c (patch)
tree9b10037279057902dcfb7a2b5a0e48e0ab761ede /dev-python/marshmallow/marshmallow-3.15.0.ebuild
parentdev-python/pudb: Bump to 2022.1.1 (diff)
downloadgentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.tar.gz
gentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.tar.bz2
gentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.zip
dev-python/marshmallow: Bump to 3.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow/marshmallow-3.15.0.ebuild')
-rw-r--r--dev-python/marshmallow/marshmallow-3.15.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/marshmallow/marshmallow-3.15.0.ebuild b/dev-python/marshmallow/marshmallow-3.15.0.ebuild
new file mode 100644
index 000000000000..f26c074cbd82
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest