summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-15 13:31:54 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-15 13:32:09 +0100
commit0842291d0ea6a9c62513692c7320f0ef85e167f5 (patch)
treed9d8cf09298a9de7769ab777b5d3b9b306307761 /dev-python/matplotlib
parentapp-admin/lastpass-cli: Respect CC (diff)
downloadgentoo-0842291d0ea6a9c62513692c7320f0ef85e167f5.tar.gz
gentoo-0842291d0ea6a9c62513692c7320f0ef85e167f5.tar.bz2
gentoo-0842291d0ea6a9c62513692c7320f0ef85e167f5.zip
dev-python/matplotlib: Backport test fix
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.5.1-test-fix-backport-2.patch22
-rw-r--r--dev-python/matplotlib/matplotlib-1.5.1.ebuild10
2 files changed, 26 insertions, 6 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-1.5.1-test-fix-backport-2.patch b/dev-python/matplotlib/files/matplotlib-1.5.1-test-fix-backport-2.patch
new file mode 100644
index 000000000000..c850d090f79d
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-1.5.1-test-fix-backport-2.patch
@@ -0,0 +1,22 @@
+From c28e1b0aebe19b7db292eb7c1b6deba8af6754e0 Mon Sep 17 00:00:00 2001
+From: Jens Hedegaard Nielsen <jens.nielsen@ucl.ac.uk>
+Date: Wed, 13 Jan 2016 13:48:06 +0000
+Subject: [PATCH] Fix new pep8 issue in legend_demo5
+
+---
+ examples/pylab_examples/legend_demo5.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/pylab_examples/legend_demo5.py b/examples/pylab_examples/legend_demo5.py
+index 699babe..5668966 100644
+--- a/examples/pylab_examples/legend_demo5.py
++++ b/examples/pylab_examples/legend_demo5.py
+@@ -41,7 +41,7 @@ def create_artists(self, legend, orig_handle,
+ lw = orig_handle.get_linewidths()[i]
+ except IndexError:
+ lw = orig_handle.get_linewidths()[0]
+- if dashes[0] != None:
++ if dashes[0] is not None:
+ legline.set_dashes(dashes[1])
+ legline.set_color(color)
+ legline.set_transform(trans)
diff --git a/dev-python/matplotlib/matplotlib-1.5.1.ebuild b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
index 9fabf36f5dca..410effc18030 100644
--- a/dev-python/matplotlib/matplotlib-1.5.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
@@ -110,7 +110,10 @@ RDEPEND="${COMMON_DEPEND}
# Other than that, the ebuild shall be fit for out-of-source build.
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${P}-test-fix-backport.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test-fix-backport.patch
+ "${FILESDIR}"/${P}-test-fix-backport-2.patch
+ )
pkg_setup() {
unset DISPLAY # bug #278524
@@ -156,11 +159,6 @@ python_prepare_all() {
-e "s:/usr/:${EPREFIX}/usr/:g" \
-i setupext.py || die
- # https://github.com/matplotlib/matplotlib/issues/5857
- sed \
- -e 's:test_pep8_conformance_examples:_&:g' \
- -i lib/matplotlib/tests/test_coding_standards.py || die
-
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die