summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-16 22:23:44 +0100
committerSam James <sam@gentoo.org>2023-08-16 22:23:51 +0100
commite85d8b4b561139b29438c13775f993292d032376 (patch)
tree8778aa8cfaf1ed6c1409f80bcff779605471b56a /dev-python/matplotlib
parentvirtual/perl-Archive-Tar: drop 2.380.0 (diff)
downloadgentoo-e85d8b4b561139b29438c13775f993292d032376.tar.gz
gentoo-e85d8b4b561139b29438c13775f993292d032376.tar.bz2
gentoo-e85d8b4b561139b29438c13775f993292d032376.zip
dev-python/matplotlib: add more baseline fails for hppa
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.7.1.ebuild14
-rw-r--r--dev-python/matplotlib/matplotlib-3.7.2.ebuild14
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.7.1.ebuild b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
index 6a3b7310439d..135d1b285cf8 100644
--- a/dev-python/matplotlib/matplotlib-3.7.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
@@ -267,6 +267,20 @@ python_test() {
;;
esac
+ if use hppa ; then
+ EPYTEST_IGNORE+=(
+ tests/test_mathtext.py
+ )
+
+ EPYTEST_DESELECT+=(
+ 'tests/test_quiver.py::test_barbs[png]'
+ 'tests/test_quiver.py::test_barbs_pivot[png]'
+ 'tests/test_quiver.py::test_barbs_flip[png]'
+ 'tests/test_text.py::test_parse_math'
+ 'tests/test_text.py::test_parse_math_rcparams'
+ )
+ fi
+
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering
grep -v system_freetype "${BUILD_DIR}"/setup.cfg \
diff --git a/dev-python/matplotlib/matplotlib-3.7.2.ebuild b/dev-python/matplotlib/matplotlib-3.7.2.ebuild
index 7406ac29a074..f6e948e0c338 100644
--- a/dev-python/matplotlib/matplotlib-3.7.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.7.2.ebuild
@@ -272,6 +272,20 @@ python_test() {
;;
esac
+ if use hppa ; then
+ EPYTEST_IGNORE+=(
+ tests/test_mathtext.py
+ )
+
+ EPYTEST_DESELECT+=(
+ 'tests/test_quiver.py::test_barbs[png]'
+ 'tests/test_quiver.py::test_barbs_pivot[png]'
+ 'tests/test_quiver.py::test_barbs_flip[png]'
+ 'tests/test_text.py::test_parse_math'
+ 'tests/test_text.py::test_parse_math_rcparams'
+ )
+ fi
+
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering
grep -v system_freetype "${BUILD_DIR}"/setup.cfg \