summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-26 07:47:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-26 07:50:09 +0200
commit9431579d4dde26fb1808d727e311c92c6849b524 (patch)
treec55b101edb8823c306d1bec39d636eb11842bc79 /dev-python/mido
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-9431579d4dde26fb1808d727e311c92c6849b524.tar.gz
gentoo-9431579d4dde26fb1808d727e311c92c6849b524.tar.bz2
gentoo-9431579d4dde26fb1808d727e311c92c6849b524.zip
dev-python/mido: Bump to 1.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mido')
-rw-r--r--dev-python/mido/Manifest1
-rw-r--r--dev-python/mido/mido-1.3.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mido/Manifest b/dev-python/mido/Manifest
index 5aa1724421c4..f5fc4f19ca0c 100644
--- a/dev-python/mido/Manifest
+++ b/dev-python/mido/Manifest
@@ -1 +1,2 @@
DIST mido-1.3.2.tar.gz 124216 BLAKE2B f6eb230ad8ec02a9a2f0e5e1b332a70334433a1decddb341b1c315b878bdc2e7aefed3527c408a3da9264e7344439a69bf28bd2b4d810c29e4f4278aee8303b9 SHA512 5f31057a972f8ecdadcd135f2ffd68f70388bb8777f6bc7fa14c84aa8c57988a4f7443283dd093930352989d8a097177c6543a38440184c705cfaf82e3aaff83
+DIST mido-1.3.3.tar.gz 124288 BLAKE2B 2119ffa5894067107ccf94a4ddcccde0365aedd942df0330e06c1a1a3645cfa8b9a1bf767a0e60616f50966cf7dfb5a1d6cc394c05269bb01ba0724573dd4164 SHA512 9a9b983b7d2cc6ea530f98df09bc84690dfc980467726217023991a680a7c3f294bb0ffac730e79dcc5a3e4afccacfb4423791df290a035260513a5f7cc26152
diff --git a/dev-python/mido/mido-1.3.3.ebuild b/dev-python/mido/mido-1.3.3.ebuild
new file mode 100644
index 000000000000..a334fa8a897e
--- /dev/null
+++ b/dev-python/mido/mido-1.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MIDI Objects, a library for working with MIDI messages and ports"
+HOMEPAGE="
+ https://pypi.org/project/mido/
+ https://github.com/mido/mido
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+portmidi rtmidi"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ portmidi? ( media-libs/portmidi )
+ rtmidi? ( dev-python/python-rtmidi[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance test
+ tests/midifiles/test_tracks.py::test_merge_large_midifile
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}