summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 12:14:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 15:15:33 +0200
commit688c2ecd719c6fe8087fbd0f242e4d70821e7d49 (patch)
treeb5f112131e59ab1524811aabfc92c0db69ca60df /dev-python/mistune/mistune-0.7.4.ebuild
parentdev-python/m2crypto: Bump to version 0.26.0 (diff)
downloadgentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.tar.gz
gentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.tar.bz2
gentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.zip
dev-python/mistune: Bump to version 0.7.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/mistune/mistune-0.7.4.ebuild')
-rw-r--r--dev-python/mistune/mistune-0.7.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-0.7.4.ebuild b/dev-python/mistune/mistune-0.7.4.ebuild
new file mode 100644
index 000000000000..782a3404807d
--- /dev/null
+++ b/dev-python/mistune/mistune-0.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.python.org/pypi/mistune https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}