summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-18 15:40:25 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-18 15:40:25 +0200
commite639aa07dfa9a768ea14d73ed9f8d9625f419cb6 (patch)
tree65619a09aa4115c5ceeb2dd0d92f754060986aae /dev-python/mkdocs-minify-plugin
parentdev-python/mkdocs-bootstrap: add 1.1.1 (diff)
downloadgentoo-e639aa07dfa9a768ea14d73ed9f8d9625f419cb6.tar.gz
gentoo-e639aa07dfa9a768ea14d73ed9f8d9625f419cb6.tar.bz2
gentoo-e639aa07dfa9a768ea14d73ed9f8d9625f419cb6.zip
dev-python/mkdocs-minify-plugin: add 0.7.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-minify-plugin')
-rw-r--r--dev-python/mkdocs-minify-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/mkdocs-minify-plugin/Manifest b/dev-python/mkdocs-minify-plugin/Manifest
index bed593366e2a..b7c0d8ea1e3e 100644
--- a/dev-python/mkdocs-minify-plugin/Manifest
+++ b/dev-python/mkdocs-minify-plugin/Manifest
@@ -1,2 +1,3 @@
DIST mkdocs-minify-plugin-0.6.4.gh.tar.gz 8792 BLAKE2B 42dae53b6918655f27f26521e84b42a97e75d7b8f1ec526165341810fce9b0c6bf0add9f451d0122b68e2543deed98a2661ccaefb4b51262fee71964ba3c5bf9 SHA512 d5adf7df838f10abad79c5790c3aefec11ac78078cc5f0640213a2e097cb251a16eba39d9aa6f53996a983d08bcd4558718754d3bd11af74cf407faab3f97453
DIST mkdocs-minify-plugin-0.7.0.gh.tar.gz 8856 BLAKE2B c61cd0817f4e224ca22b71c395a4bfd0d144cf73ac39417dd2293176e98f31fd797a43c3c43d38a0232c5e287c9b6a84273171bdbf4d2eda5ce757f5b19188f8 SHA512 d14b2050bc8acca03532c46d44418d37401a6bd8dafe727a8331e46a57173044f8bb7f461c62eaa3bcd6ccd88065d9a999fcdfdce9b04d5cd62dd858c5ab0d2b
+DIST mkdocs-minify-plugin-0.7.1.gh.tar.gz 8935 BLAKE2B d5b29515a40068dd01894f7dffc54ad627fbaa6e3efaea91c19ab4fb3571dcfba00f1ec9f2e23869dc4bd2bf97dec2a872a8e91fd928dc628f6a0fc8fe455539 SHA512 c8d732cf7906c37b754ad7d5c2132a88d1175f5da453aa53ac390ae2c0461e8a8ed6ffb88c64c8bc627be593e5f9e1f9b8d9e44181c29bee60188d4a9a3a254b
diff --git a/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild
new file mode 100644
index 000000000000..55254d02d421
--- /dev/null
+++ b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An MkDocs plugin to minify HTML and/or JS files prior to being written to disk"
+HOMEPAGE="
+ https://github.com/byrnereese/mkdocs-minify-plugin
+ https://pypi.org/project/mkdocs-minify-plugin/
+"
+# pypi sdist lacks tests, as of 0.6.4
+SRC_URI="
+ https://github.com/byrnereese/mkdocs-minify-plugin/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/csscompressor-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.1[${PYTHON_USEDEP}]
+ >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jsmin-3.0.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # this is a fork of htmlmin with the same patches that we have
+ sed -i -e '/htmlmin2/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PATH=${T}:${PATH}
+ cat > "${T}"/mkdocs <<-EOF || die
+ #!/bin/sh
+ exec "${EPYTHON}" -m mkdocs "\${@}"
+ EOF
+ chmod +x "${T}"/mkdocs || die
+ epytest
+}