summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-08 01:14:42 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-08 01:52:14 +0100
commit857b9600a94dc7d03f943200a60b60ace07f037d (patch)
tree40abd7a464b6ffcf78a3fd72cb5918cb41f94341 /dev-python/mkdocs-monorepo-plugin
parentdev-python/mkdocs-htmlproofer-plugin: new package, add 0.13.1 (diff)
downloadgentoo-857b9600a94dc7d03f943200a60b60ace07f037d.tar.gz
gentoo-857b9600a94dc7d03f943200a60b60ace07f037d.tar.bz2
gentoo-857b9600a94dc7d03f943200a60b60ace07f037d.zip
dev-python/mkdocs-monorepo-plugin: new package, add 1.0.5
Bug: https://bugs.gentoo.org/907820 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-monorepo-plugin')
-rw-r--r--dev-python/mkdocs-monorepo-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-monorepo-plugin/metadata.xml13
-rw-r--r--dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/mkdocs-monorepo-plugin/Manifest b/dev-python/mkdocs-monorepo-plugin/Manifest
new file mode 100644
index 000000000000..d1dc8d0474e3
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/Manifest
@@ -0,0 +1 @@
+DIST mkdocs-monorepo-plugin-1.0.5.tar.gz 9510 BLAKE2B 96b63fabe344f99aaefd0d3d0f547f0695fcee5b7f6d5ce027fc52ef27c1a70353c3835d0a0d02c753c48a67123bc6776a8060fa0a07640ca26f008df8f3611d SHA512 ed3c011d9a7b5a32868a4a16cbdfa1fd4ce036da2d73d59645aa5f42895f12ce7fe6d1681b53d72248b09fbdb343b2cfad3846e7005dbc8977c7ae40b8e29b30
diff --git a/dev-python/mkdocs-monorepo-plugin/metadata.xml b/dev-python/mkdocs-monorepo-plugin/metadata.xml
new file mode 100644
index 000000000000..62f26ac9e62a
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">mkdocs-monorepo-plugin</remote-id>
+ <remote-id type="github">backstage/mkdocs-monorepo-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
new file mode 100644
index 000000000000..e0e42827eeb2
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build multiple documentation folders in a single Mkdocs"
+HOMEPAGE="
+ https://backstage.github.io/mkdocs-monorepo-plugin/
+ https://pypi.org/project/mkdocs-monorepo-plugin/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/mkdocs-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.1[${PYTHON_USEDEP}]
+"
+
+# Data files required by this test are not included in PyPI tarballs,
+# and upstream has not tagged any releases in their GitHub repository since 2019.
+EPYTEST_DESELECT=(
+ mkdocs_monorepo_plugin/tests/test_plugin.py::TestMonorepoPlugin::test_plugin_on_config_with_nav
+)
+
+distutils_enable_tests pytest