summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-12 20:53:16 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-12 21:15:48 +0200
commitac8f81058889929409edf7bc66b96a6ded4ea92c (patch)
treedec4cf126de1b697e2f8f260b838bf319ad3b76f /dev-python/nautilus-python
parentapp-text/calibre: remove old version 3.15.0 (diff)
downloadgentoo-ac8f81058889929409edf7bc66b96a6ded4ea92c.tar.gz
gentoo-ac8f81058889929409edf7bc66b96a6ded4ea92c.tar.bz2
gentoo-ac8f81058889929409edf7bc66b96a6ded4ea92c.zip
dev-python/nautilus-python: bump to 1.2.2
Maintainer timeout, plus I co-maintain nautilus itself. No python3 support is introduced yet, as that would break existing packages in tree without a more careful migration process. Closes: https://bugs.gentoo.org/665764 Bug: https://bugs.gentoo.org/673038 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'dev-python/nautilus-python')
-rw-r--r--dev-python/nautilus-python/Manifest1
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.2.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
index f25bfd11af08..fb58721d3073 100644
--- a/dev-python/nautilus-python/Manifest
+++ b/dev-python/nautilus-python/Manifest
@@ -1 +1,2 @@
DIST nautilus-python-1.1.tar.xz 239392 BLAKE2B a2baef3cb4d96d97b4b3e9b7644388c8778e1579ee0b32ff2a60baae45baa2d60dbcc61108fc3fe9e8a7193cf4c6ad82f8ffc2f175419e0937bacecc98551c51 SHA512 e721f46414a3efa4b5f5ec3f56cc00a308ec010a7a0612cef975d6f436494701f8bdbed39bdb5186c8013a582c7e63288a1c60adc4b8967c9ec69d6301a50fef
+DIST nautilus-python-1.2.2.tar.xz 269220 BLAKE2B 9f2b5acc20727acf4464297bc008e8be0bb45ed418601e3658405e90eb3d56306f9aece402948491d5423d58cd261cee5cacbd39dd185957c4d72c90f877842e SHA512 541ab9e6ac15b06994cf475237e5588d21f4b9f71bb562f4bd9d976f79849a29912080de0b16c14406b052bec15c2c754381bf36e15b340d1f8e76c83a2464bc
diff --git a/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild b/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild
new file mode 100644
index 000000000000..291a0ebb6d43
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; configure itself
+# requires pygobject:3 or :2 and >=nautilus-2.32
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=gnome-base/nautilus-3[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}