summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 15:22:46 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 15:23:38 +0200
commit99fed13db271f45c526df0c31ca700946f93c6d7 (patch)
treed1486d5cdfa65bfcb769a1e95436fd806b2c332c /dev-python/nbclassic
parentsys-kernel/gentoo-sources: add 5.19.14 (diff)
downloadgentoo-99fed13db271f45c526df0c31ca700946f93c6d7.tar.gz
gentoo-99fed13db271f45c526df0c31ca700946f93c6d7.tar.bz2
gentoo-99fed13db271f45c526df0c31ca700946f93c6d7.zip
dev-python/nbclassic: add 0.4.4
Closes: https://bugs.gentoo.org/857114 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest1
-rw-r--r--dev-python/nbclassic/nbclassic-0.4.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index da66ecf0d3f8..d3f37a3226bc 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1 +1,2 @@
DIST nbclassic-0.3.7.tar.gz 15973 BLAKE2B a26a975fa8711c41a199e0b88b5ec83aefa4b812fce6ab4a765aa4920fae6b863519dbae556d663bf761a866a26ee6fe7c322c947312b89770a34f2a5b570455 SHA512 3ceaeeafa7e56d17cda29e4c86b4cb5f44517721b47e41ad1ac535704b8f460d88a5feb280ad8a9cef78366581e08c94837cab4ef2eae8dbce2ded183a787ea2
+DIST nbclassic-0.4.4.tar.gz 19873779 BLAKE2B ebdca5cb80de439f305406b0507f460a600c03a8fbb90b28d962974147d9e94f374282c02653019f2a519078812c2b25bbbcc9c12befbcdac72f305135437a70 SHA512 f7b425ea78f555d2d9d60e221fd3d3f551f7fa4ed4f6178a0596ff59ec0c1ead212f2102aeeaedf95ec3c5f7c2ea7536c21ff5df9f5b78b9718ab9bdf23159bf
diff --git a/dev-python/nbclassic/nbclassic-0.4.4.ebuild b/dev-python/nbclassic/nbclassic-0.4.4.ebuild
new file mode 100644
index 000000000000..be7c8b770640
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=jupyter
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyter_server-1.17.0[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+ doc? (
+ virtual/pandoc
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/nbsphinx \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/myst_parser \
+ dev-python/ipython_genutils
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}