summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-25 04:42:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-25 04:55:01 +0200
commit3b8c61afecb4601a41699934a69cfc65a83dccfd (patch)
tree55b85062148e8e834dd495248247accf98d5fc52 /dev-python/nbsphinx
parentdev-python/prometheus-client: Bump to 0.17.0 (diff)
downloadgentoo-3b8c61afecb4601a41699934a69cfc65a83dccfd.tar.gz
gentoo-3b8c61afecb4601a41699934a69cfc65a83dccfd.tar.bz2
gentoo-3b8c61afecb4601a41699934a69cfc65a83dccfd.zip
dev-python/nbsphinx: Bump to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.9.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index 45d773e451b1..00e0536bc8ac 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1 +1,2 @@
DIST nbsphinx-0.9.1.tar.gz 171587 BLAKE2B 38796379102f7488b58e0a4ca720b6800edc11477935c782dbd9124d96fb8587f5cd51b01f95f60f1372bafc5177e68a61a61c9d20261078a8421001e6936196 SHA512 d18c3da6b202c22dfdbb9ddfbb5b61af97200aaf75712f0e6a0221089c155faac9bca61cb0d552c231456e095f3303c59a9f23a99405dacf4b99117b929e6196
+DIST nbsphinx-0.9.2.tar.gz 171754 BLAKE2B 6bb73034b7f24c39c2d79e9beab623c46c07d9dd583a71920b83a6561e7f2899474db3edbb7b64386f4f41e1fb7960e942ea8327387ef2e0f1d3745627a3ade4 SHA512 b5e371e3177f03e72d87059d0c06cb4787afe255926e9f2440ea0c753f5457974535f42c98bd5bb289752151400612f28de98e1b36e6865b26790e56d1f78b80
diff --git a/dev-python/nbsphinx/nbsphinx-0.9.2.ebuild b/dev-python/nbsphinx/nbsphinx-0.9.2.ebuild
new file mode 100644
index 000000000000..a29963c7e93e
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"