summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-29 20:58:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-29 20:58:49 +0300
commitb3a6e2aab75c2f9ffd0e832403b8f25612d3da05 (patch)
tree0596c0932538a63f86a6d83d58b55b0e4a565d8c /dev-python/nbxmpp
parentdev-python/chameleon: add 4.1.0 (diff)
downloadgentoo-b3a6e2aab75c2f9ffd0e832403b8f25612d3da05.tar.gz
gentoo-b3a6e2aab75c2f9ffd0e832403b8f25612d3da05.tar.bz2
gentoo-b3a6e2aab75c2f9ffd0e832403b8f25612d3da05.zip
dev-python/nbxmpp: add 4.3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nbxmpp')
-rw-r--r--dev-python/nbxmpp/Manifest1
-rw-r--r--dev-python/nbxmpp/nbxmpp-4.3.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index 9cc68269550f..cf39276b2e9b 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,3 +1,4 @@
DIST python-nbxmpp-3.2.5.tar.bz2 132029 BLAKE2B 846f3b47c3a9a95cf1fa1b557a007fd4901fb4acaa3160ea4b9b1cdff1e9d2c3e64bc5251b739d816f3f1c449c350d1ac44c14cbef87d14fe5a6450418451007 SHA512 577f8c7b0f5a7c69b4d980bff93f0a208ab0a660d731eb95ec63b76583194b94bd9d9f6b10fcac3951a6e6afb5d0c4da2140cbc17ef653f19ec6957b5d2e5f04
DIST python-nbxmpp-4.3.1.tar.bz2 135981 BLAKE2B eb14bf40448fc49cd2656d4ffdafcbe66e4d91d371377f976cc1030067830f47cdd1a27b7c28f0d0a7a4292225913e55db12b6dfb7cc2e5f4ffe230f3aef0e51 SHA512 da69a54efed5c906d8c6e5a093254c0b86d21071403838c2cf969b2d969ea4647c3153fdc4231efa5ecce00eff8989a83e818e9ff7590964d25167878ae93adc
DIST python-nbxmpp-4.3.2.tar.bz2 136430 BLAKE2B 9f282ab7a5df4c674f83e01282f7d34af8e9f5cccc4546d8462e46e84a032847f4e7a21df1852f46a41f07a26c0ef9957fffe068711d08aa73545a35452c24c4 SHA512 6aca60d354c0ffc46b95cce13b17a261aa9bb9f3f7f3292499f0e994806377472c74dc5407aee71c773ab76c62a7958899b7959d5ec95a367c0e4b4f7c104c02
+DIST python-nbxmpp-4.3.3.tar.bz2 136583 BLAKE2B 2b5a8cf976a44747c9ab245c6744d6b9b797e5634cff689c17f929107b5ed9e01273cf34e96427d26df0397c70d7fdb7a9f4db095d7582b00e464bea4ea9f4b5 SHA512 0c433821b88103418a9326519f8793ae5b430901141333b10a747e60eeec63d576020b3b32b610a5dd52a4a4ec22572eb8728d92460411bdc92b4c54d3764980
diff --git a/dev-python/nbxmpp/nbxmpp-4.3.3.ebuild b/dev-python/nbxmpp/nbxmpp-4.3.3.ebuild
new file mode 100644
index 000000000000..8eff1b51bf70
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-4.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest