summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-30 05:24:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-30 05:24:02 +0200
commit3abfd709f0ee4f436f66f8aba6fb48d949974ab8 (patch)
treef0a0c06befb16bb181b145b287ae78f263e582ae /dev-python/nose2
parentdev-python/frozendict: Bump to 2.3.8 (diff)
downloadgentoo-3abfd709f0ee4f436f66f8aba6fb48d949974ab8.tar.gz
gentoo-3abfd709f0ee4f436f66f8aba6fb48d949974ab8.tar.bz2
gentoo-3abfd709f0ee4f436f66f8aba6fb48d949974ab8.zip
dev-python/nose2: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.13.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index 6f54fb86834d..b768c20f828d 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.12.0.gh.tar.gz 168454 BLAKE2B cce76a046c4285d7dbe6ad6a049628e23ddebd36eda4457eecb4f0e14b1559f8bd7be5bc80aa99bf965f530575c3f5e245d1a30b4115d5e8ee0aa4c8d93fb8f0 SHA512 7f1462613b7d38a77cd0764f721be4223b8f4ae4694c49ba416a076c321e07484969ee1a7c2d2f89484c0c3b2a96e74d6a42321981af4930ebe5f63f07df7755
+DIST nose2-0.13.0.gh.tar.gz 159435 BLAKE2B 33a0d395045933c41cd22c8c30a933fb0fc14a21abf5aa4af459687e28126b89f5aad4e57aa4b06a303c50581e785f38708c0071e9cfe37c609046310540c595 SHA512 d2f16eddab75cecd864005eee3d29159e2c83d843c79df73f65d6dfacab7c195ae9b5e6d059848689d6b71da89035df8eb73d277560c1967d732c1522b54bfc5
diff --git a/dev-python/nose2/nose2-0.13.0.ebuild b/dev-python/nose2/nose2-0.13.0.ebuild
new file mode 100644
index 000000000000..c81ddcf8635d
--- /dev/null
+++ b/dev-python/nose2/nose2-0.13.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+SRC_URI="
+ https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}