summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 23:45:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-28 17:52:47 +0200
commit21440396049d150f1e1943d2c645b55c5420de9b (patch)
tree2244cd47f12e12aa92477a1eec53d97fe33989df /dev-python/olefile
parentdev-python/nose: Remove py2.7 in revbump (diff)
downloadgentoo-21440396049d150f1e1943d2c645b55c5420de9b.tar.gz
gentoo-21440396049d150f1e1943d2c645b55c5420de9b.tar.bz2
gentoo-21440396049d150f1e1943d2c645b55c5420de9b.zip
dev-python/olefile: Remove py2.7 in revbump
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/olefile')
-rw-r--r--dev-python/olefile/olefile-0.46-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.46-r1.ebuild b/dev-python/olefile/olefile-0.46-r1.ebuild
new file mode 100644
index 000000000000..cf09eeb237d8
--- /dev/null
+++ b/dev-python/olefile/olefile-0.46-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest