summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:30:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:07 +0100
commit8aed533cd0c1cdc9d65d3b0518df2b024c6da80e (patch)
treef54254356faa6876f82ffb57df683b236594dd7f /dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild
parentdev-python/oslo-log: Bump to 4.7.0 (diff)
downloadgentoo-8aed533cd0c1cdc9d65d3b0518df2b024c6da80e.tar.gz
gentoo-8aed533cd0c1cdc9d65d3b0518df2b024c6da80e.tar.bz2
gentoo-8aed533cd0c1cdc9d65d3b0518df2b024c6da80e.zip
dev-python/openstackdocstheme: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild')
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild
new file mode 100644
index 000000000000..ddf491533957
--- /dev/null
+++ b/dev-python/openstackdocstheme/openstackdocstheme-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Theme and extension support for Sphinx documentation"
+HOMEPAGE="https://docs.openstack.org/openstackdocstheme/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+"