summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-12 07:20:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-12 08:33:09 +0100
commitf3e2ceb36c9c2613028d7ef4d3a07b2e9723aa55 (patch)
tree07af99fbfbcc977c563bf321b1fbcd9fab412a9d /dev-python/peewee
parentdev-python/pytest-asyncio: Bump to 0.20.2 (diff)
downloadgentoo-f3e2ceb36c9c2613028d7ef4d3a07b2e9723aa55.tar.gz
gentoo-f3e2ceb36c9c2613028d7ef4d3a07b2e9723aa55.tar.bz2
gentoo-f3e2ceb36c9c2613028d7ef4d3a07b2e9723aa55.zip
dev-python/peewee: Bump to 3.15.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.15.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 07b426bc716f..bacab82d3ac8 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
DIST peewee-3.15.3.gh.tar.gz 906883 BLAKE2B 4cc76b4288e8b8e36b4df2f42e31c8eeec314b2af28612d272699e6cc79d836fdc8800f18883e721fd98ca04bf58b0ed26ba61ab36280d28a32d1ca18ab6577c SHA512 bf297423178fca432add6e1ef2aba41ebd87d2bdc34e47872b5c35573dd9eedd42a290cad53dfce68e0bc0e07bb537064c25bf6b43b43d678302d6345eaa35a4
+DIST peewee-3.15.4.gh.tar.gz 908759 BLAKE2B 5bb53598f44c75f4b819d7aa032a2bc812f1e6de415b4cc01e22e521e4881dd409ceaf26435ddfcf08167c5193594917f23b15ae91f037fa4216d78752e77247 SHA512 9042e1c4fffac0c395500597981ab4732383c273e2b7f2b129b2b7702d9762772a219bb848a1f0aff802c468f38327f629df1c49028858451578115cf0811a13
diff --git a/dev-python/peewee/peewee-3.15.4.ebuild b/dev-python/peewee/peewee-3.15.4.ebuild
new file mode 100644
index 000000000000..82b01219bc7a
--- /dev/null
+++ b/dev-python/peewee/peewee-3.15.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}