summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-05-19 20:59:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-05-19 20:59:06 -0500
commit0385845a9e0ed704ddae8a5354460241974a8487 (patch)
treeac4e152660c2175e09bb96a81a80ceddc9f02bc6 /dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild
parentdev-python/misaka: bump python to py10 (diff)
downloadgentoo-0385845a9e0ed704ddae8a5354460241974a8487.tar.gz
gentoo-0385845a9e0ed704ddae8a5354460241974a8487.tar.bz2
gentoo-0385845a9e0ed704ddae8a5354460241974a8487.zip
dev-python/pelican-minify: bump python_compat (add py10)
Closes: https://bugs.gentoo.org/845774 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild')
-rw-r--r--dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild b/dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild
new file mode 100644
index 000000000000..8e2494d08d88
--- /dev/null
+++ b/dev-python/pelican-minify/pelican-minify-0.9-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="An HTML minification plugin for Pelican, the static site generator"
+HOMEPAGE="https://pypi.org/project/pelican-minify/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/joblib-0.9[${PYTHON_USEDEP}]
+ >=app-text/htmlmin-0.1.5[${PYTHON_USEDEP}]
+ >=app-text/pelican-3.1.1[${PYTHON_USEDEP}]"